ASI 174MM and Firecapture - endless issues - looking for alternatives!

Use this section to discuss "standard" Baader/Coronado/ Lunt SolarView/ Daystar, etc… filters, cameras and scopes. No mods, just questions/ answers and reviews.
madman
The Sun?
The Sun?
Posts: 6
Joined: Tue Aug 22, 2017 6:09 pm

ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by madman » Tue Aug 22, 2017 6:20 pm

Been using this camera for some months now and yesterday ran a dual setup with my Mod 6D in a Tak106 and then my quark, ASI174mm in my Explore Scientific ED80.

Ever since I've owned it, the 174 regularly disconnects from Firecapture and often won't let me back in or when it does, it does so at some very low fps (e.g. 40 vs. the 200+ I get when it runs right - which is never). When it is stable, [no religion please] forbid you want to exit and comeback in again as anything higher than the 2.5 beta version of Firecapture leaves itself planted in memory and even task manager can't kill the process, meaning complete re-boots.

What I have tried: Dedicated USB 3.0 port, multiple cables (active and not active), multiple USB traffic settings, multiple versions of firecapture (beta and non-beta), multiple versions old and new of 174 drivers, etc...

No support from ZWO available at all.

If it weren't for my Canon 6D in the Tak with a simple Baader film filter, I would have gotten nothing yesterday - and I'm fed up. I'm not sure which to blame - but I'm seriously thinking about taking the camera outback and shooting it with a 12 gauge. Can't figure out how to shoot firecapture, but will have to find a virtual way to do that as well.

Any suggestions on a better camera with some responsive support? I like the chip (174) but I would prefer a camera that contained it from folks that can write a driver and respond to support inquiries. I miss my Flea3 and even the Flycapture software that I used to use. Horrible stuff but at least it didn't crash incessantly.

Looking for recommendation on a 174MM chip in a well supported body (or a better chip if you all can find one that suffices for planetary and solar like the 174 seems to have speced out to) and an alternative to Firecapture (other than SharpCap which I cannot get a decent frame rate out of).

Maybe it's time for a new computer but any advice welcome.

Thanks in advance for suggestions!

Mike



bart1805
Almost There...
Almost There...
Posts: 650
Joined: Mon Feb 06, 2017 9:04 pm
Location: The Netherlands

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by bart1805 » Tue Aug 22, 2017 8:23 pm

Hi Mike,
Since about two weeks I am experimenting with a PGR Grasshopper with the same chip. I had to go back to version 2.3 of Firecapture cause the newer versions seem to capture by default in RAW and not mono. This is only the case for PGR camera's so it seems.
I tried Sharpcap, fps to low. Genika Astro went quite ok. But version 2.3 of FC works the best. I do have problems with my laptop (1.7 GGHz / 200 GB SSD and 4 GB RAM). Biggest problems are that the RAM memory seems to low. And I have to watch out that the SSD does not get to full. So halfway through a session put everything on an external HD.
The settings in FC helped me a lot. Use the RAM buffer (it says it is experimental, but it works). And check if you have got the right settings for your laptop (single/dual or quad core).
Good luck! Bart.



madman
The Sun?
The Sun?
Posts: 6
Joined: Tue Aug 22, 2017 6:09 pm

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by madman » Tue Aug 22, 2017 9:21 pm

Thanks Bart. I think the best thing to do at this point is get a dedicated new desktop. I never operate the laptop without power anyway. My only problem is I want one with Windows 7 64, not Win 10 and not sure if that's possible. Appreciate the insight though and I loved the PGR cameras. At least they pick up the phone!



User avatar
Merlin66
Librarian
Librarian
Posts: 3611
Joined: Tue Dec 13, 2011 1:23 pm
Location: St Leonards, Australia
Has thanked: 15 times
Been thanked: 70 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Merlin66 » Tue Aug 22, 2017 10:59 pm

Mike,
I bought the ASI 174 for fast frame data collection on the spectroheliograph.
I also had to upgrade my laptop to a FAST, sexy MSI gaming machine with good USB3 port, plenty of memory and a fast SSD drive.
I'm happy with the FireCapture software and I can achieve >500 fps on the required ROI frame.
What ever the real problem, I don't think it is the camera.


"Astronomical Spectroscopy - The Final Frontier" - to boldly go where few amateurs have gone before
https://groups.io/g/astronomicalspectroscopy  
http://astronomicalspectroscopy.com
"Astronomical Spectroscopy for Amateurs" and
"Imaging Sunlight - using a digital spectroheliograph" - Springer

madman
The Sun?
The Sun?
Posts: 6
Joined: Tue Aug 22, 2017 6:09 pm

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by madman » Wed Aug 23, 2017 12:29 am

I am starting to concur with you Merlin66. I failed to mention that I tend to run two cameras (plus a guidecam for DSO if I'm doing that), so my USB traffic is high. I have not heard of MSI before but will be checking them out. Last two gamer desktops I have, although not used for multiple cameras - only gaming and video editing - are still performers after 7+ years. One homebuilt and the other a water-cooled Dell XPS. As long as it's got a motherboard with enough native USB 3's and some open slots, I'm all about it. Not going the laptop route any more. I can't see that fairing well in the summer heat in a dome here in GA.

Thank you as well.



User avatar
Astrograph
Im an EXPERT!
Im an EXPERT!
Posts: 239
Joined: Tue Aug 05, 2014 1:00 pm
Location: London
Been thanked: 39 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Astrograph » Thu Aug 24, 2017 11:46 am

As a supplier of both ZWO and PGR/FLIR cameras and one that tests with Firecapture, SharpCap and Genika, here are my two pennies worth

1 - Firecapture needs the latest version of Java running on your PC or it will do some strange things.
2 - Sharpcap should run the ASI natively.
3 - Genika should run fastest (if the 64bit version) and allows integration of an SSM
4 - ASI cameras can be flakey if the drivers are not installed correctly. Early drivers seem to have problems but all later seem fine
5 - USB3 outputs on computers are very variable. The USB3 power spec is quite low. The PGR Grasshopper's power consumption is 4.5w which is the limit of USB3. On my basic i3 laptop one will work fine. I had a customer with a high end i7 laptop who got artifacts. We traced the problem to insufficient power. PGR cameras can be powered separately (and they recommend this for maintaining frame rate) which solves this problem and also lowers the already low noise. I have no info for the ASI174's power demands but this is somewhere I would look. You can get split USB leads that allow you to provide more power.
6 - As an aside, the PGR (now FLIR) IMX174 Grasshopper is the fastest etc, etc of all the 174 cameras.
7 - Using any large chip high frame rate camera with a normal HDD is a non starter. Any 2MP camera running 40FPS+ will fill up a RAM buffer faster than a normal HDD can write. Firecapture just crashes when that happens. Always use an SSD
8 - The IMX174 running flat out will use up nearly all of USB3's capacity. Laptops often have a single USB3 controller, so all the USB connections share this capacity. A desktop with separate cards can have a controller for each port. So if you have lots of USB devices running at once the camera is unlikely to be able to operate flat out.
9 - The mode of the camera will affect its speed. On a PGR camera you have RAW and Mono and each has bit depth options. RAW 8bit is fastest, Mono 16 (actually 14bit) slowest. The difference can be quite large. The ASI does not have a frame buffer, so any frames lost are lost. RAW mode tends to be the cause of dropped frames. PGR cameras have frame buffers which are used in Mono mode. These result on no dropped frames but the trade off is speed.

My own imaging gear consists of a cheap Acer i3 / 4GB Ram laptop that only has astro applications on it. No anti-virus, office or any other rubbish that will slow it up. I fitted it with an SSD. I can capture with a PGR Grasshopper with IMX252 (3.2MP) at 125FPS all day with no problems using Firecapture or Genika. The IMX252 is right on the limit of USB3's capacity and takes more of it than the 174.



madman
The Sun?
The Sun?
Posts: 6
Joined: Tue Aug 22, 2017 6:09 pm

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by madman » Thu Aug 24, 2017 12:12 pm

Thank you Astrograph! I really appreciate all of the help this forum has provided, feel bad that I am blaming hardware and software when it is likely my older Vaio that needs to be trashed and replaced with something more capable!



User avatar
_Zakalwe
Im an EXPERT!
Im an EXPERT!
Posts: 210
Joined: Sun Mar 23, 2014 7:54 am
Has thanked: 68 times
Been thanked: 55 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by _Zakalwe » Wed Sep 13, 2017 7:35 am

I'd also look at the USB3 cables that you are using. I have a 3 metre cable that causes the camera to drop frames and disconnect in FireCapture. Stick a 2 metre in and it works fine. This may suggest a power issue as Rupert (Astrograph) has suggested.



madman
The Sun?
The Sun?
Posts: 6
Joined: Tue Aug 22, 2017 6:09 pm

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by madman » Wed Sep 13, 2017 12:00 pm

Thanks Zakalwe and that could be an issue as well. As for now, I have bought a new higher end gaming laptop, which will be the foundation of the observatory control. Acer Predator I7 w/ 32g RAM and 8g GPU RAM, SSD, etc. If this doesn't work, I will give up and take up knitting.



denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Tue Jun 23, 2020 12:52 pm

Hi, don’t know where else to post this, may be someone can redirect me if necessary.
Any way I have two issues, my scope is Lunt 50 ha and I have the latest version of Java and FireCapture. I firstly tried with my FLIR Grasshopper imx174 but could not get focus, is there a way of getting closer in, I have a shorter adapter that fits directly onto the blocking filter (600) any ideas.
Then I switched to my ZWO 120 mm camera and although I achieved focus there seemed to be a delay of about 1-2seconds, so getting focus was impossible. I have watched a few videos on F.C. but none of them cover of my issues. Can anyone help please.



User avatar
Astrograph
Im an EXPERT!
Im an EXPERT!
Posts: 239
Joined: Tue Aug 05, 2014 1:00 pm
Location: London
Been thanked: 39 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Astrograph » Tue Jun 23, 2020 1:09 pm

Out of the box, a Lunt 50 is only setup for visual. The scope has very little backfocus. The way to fix the problem and allow use with the FLIR is to replace the T2 clamp on the blocking filter with a shorter one allowing the sensor to get closer. Its a long time since I setup an LS50 for a customer for imaging so I cannot remember if simply replacing the standard T2 clamp with a shorter 15mm clamp (see http://astrograph.net/epages/www_astrog ... ID=4032155 ) is all you need. For some reason I seem to remember that when I used a Grasshopper on an LS50 it had a C to T2 adapter and only a 10mm T2 extension on it. I could be wrong on that.

The Grasshopper has 17.5mm back focus from its threaded nose. If you have then added a nose to this that is probably longer than the standard clamp so the camera is sitting further away than the ASI is.

You need to think in terms of where the field stop of an eyepiece would be sitting in the standard clamp. That is where the sensor needs to be.



denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Tue Jun 23, 2020 1:41 pm

Hi, again, I have the shorter t2 clamp and that is the one I was using. I am contemplating purchasing a Daystar solar scout 60ss and hopefully the Grasshopper will work with that, if not I will try my zwo 120 mm and see if that works. I will keep you posted.



User avatar
Astrograph
Im an EXPERT!
Im an EXPERT!
Posts: 239
Joined: Tue Aug 05, 2014 1:00 pm
Location: London
Been thanked: 39 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Astrograph » Tue Jun 23, 2020 2:04 pm

OK, but where was the sensor on the Grasshopper?

Look at an eyepiece and note where the field stop is. Put it in the LS50 and focus. Note where the field stop would be inside the clamp. That is where the sensor needs to be. Does not matter which camera. You can't just suck it and see, you need to work it out.

Not sure a Solar Scout will be much of an upgrade.



denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Tue Jun 23, 2020 2:28 pm

I will check things out tomorrow as I now have to go out for a while in which timethe Sun will have gone below the horizon.



User avatar
marktownley
Librarian
Librarian
Posts: 29794
Joined: Tue Oct 18, 2011 5:27 pm
Location: Brierley Hills, UK
Has thanked: 2876 times
Been thanked: 1161 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by marktownley » Tue Jun 23, 2020 5:01 pm

I wonder recommend the solar scout as an upgrade either. Has the camera nosepiece got a shoulder on it? Is it a short nosepeice?


Image
http://brierleyhillsolar.blogspot.co.uk/
Solar images, a collection of all the most up to date live solar data on the web, imaging & processing tutorials - please take a look!

denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Tue Jun 23, 2020 6:25 pm

Hi, yes there is a small shoulder on the camera but when I try to fit it the brass ring within the clamp does not hold the camera. I really don’t know how to get the sensors close enough to get focus. Is there an adapter that would fit directly onto the blocking filter that would allow me to attach the camera to it.



User avatar
Astrograph
Im an EXPERT!
Im an EXPERT!
Posts: 239
Joined: Tue Aug 05, 2014 1:00 pm
Location: London
Been thanked: 39 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Astrograph » Wed Jun 24, 2020 10:53 am

As I said, you have to measure it.

Thinking more about it I am almost certain that for the Grasshopper I used a C to T2 adapter

http://astrograph.net/epages/www_astrog ... /AGTST2-CS

and a 10mm T2 extension.

This positions the sensor (which is basically where the little cross head screw is on the Grasshoppers body) roughly where the end of an eyepiece would be using the original clamp.



denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Wed Jun 24, 2020 1:23 pm

Hi, I have one of those and shall try it ASAP.
Can anyone advise as to why there is a delay when using FireCapture?



User avatar
Astrograph
Im an EXPERT!
Im an EXPERT!
Posts: 239
Joined: Tue Aug 05, 2014 1:00 pm
Location: London
Been thanked: 39 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Astrograph » Wed Jun 24, 2020 1:27 pm

If its a delay in seeing an adjustment then check your frame rate. If you were capturing at 1 FPS as opposed to 50 FPS then you will see a delay



User avatar
marktownley
Librarian
Librarian
Posts: 29794
Joined: Tue Oct 18, 2011 5:27 pm
Location: Brierley Hills, UK
Has thanked: 2876 times
Been thanked: 1161 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by marktownley » Thu Jun 25, 2020 6:40 am

denababy wrote:
Wed Jun 24, 2020 1:23 pm
Can anyone advise as to why there is a delay when using FireCapture?
What delay? I've never had one?


Image
http://brierleyhillsolar.blogspot.co.uk/
Solar images, a collection of all the most up to date live solar data on the web, imaging & processing tutorials - please take a look!

denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Fri Jun 26, 2020 9:38 am

Hi, I have dropped the fps down to 45 but there is still a delay o matter which camera Iuse. WZO 120 mm and WZO 120 mc as well as my Pointgrey imx174.



User avatar
Astrograph
Im an EXPERT!
Im an EXPERT!
Posts: 239
Joined: Tue Aug 05, 2014 1:00 pm
Location: London
Been thanked: 39 times
Contact:

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by Astrograph » Fri Jun 26, 2020 10:01 am

I assume you mean ZWO!

If you have a problem with three different cameras then its most likely a computer problem. In FireCapture there is a graphic that shows RAM and HDD usage. If the RAM buffer becomes full then capture will be affected. If the HDD is the problem FireCapture would normally crash. The ZWO cameras are far lower performance than the Point Grey camera and would place less demands on the RAM / HDD. Therefore check these areas. You should also make sure your drivers are up to date. It would be worth you confirming the spec of your PC and also how you are connecting the cameras. i.e. USB 2 or 3. I the latter that you are plugged into a USB 3 socket on your PC.



User avatar
PDB
Almost There...
Almost There...
Posts: 614
Joined: Mon Aug 15, 2016 4:23 pm
Location: Belgium
Been thanked: 47 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by PDB » Fri Jun 26, 2020 10:25 am

Also check the "display" frame rate. (button left above the display screen)
That regulates your view-framerate. Try setting it to MAX.

Paul


None of my posts or images may be shared on Facebook, Twitter or any other social media other than SolarChat without permission.

denababy
Ohhhhhh My!
Ohhhhhh My!
Posts: 152
Joined: Thu Jan 25, 2018 12:01 pm
Been thanked: 5 times

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by denababy » Fri Jun 26, 2020 12:36 pm

Hi, I connected my zwo cameras through usb2 port and the PG through a usb3.
Not checked the display frame rate but will do That next.
I get a message that there are a few drivers out of date, the machine, Laptop Dell 15 5000, is about 1 year old if that. if I click to update the drivers will it cost me? I wish I knew about computers, it seems a dark world to me.



nfotis
The Sun?
The Sun?
Posts: 6
Joined: Wed Jun 10, 2020 5:01 pm
Location: Athens, Greece
Has thanked: 4 times
Been thanked: 1 time

Re: ASI 174MM and Firecapture - endless issues - looking for alternatives!

Post by nfotis » Tue Jul 07, 2020 5:30 pm

denababy wrote:
Fri Jun 26, 2020 12:36 pm
I get a message that there are a few drivers out of date, the machine, Laptop Dell 15 5000, is about 1 year old if that. if I click to update the drivers will it cost me? I wish I knew about computers, it seems a dark world to me.
As far as I know, driver updates are free. These are usually done automagically by the system every time the computer hardware changes.

N.F.



Post Reply