Page 1 of 1

Very slow

Posted: Wed Jan 08, 2020 8:41 am
by Montana
Hello,
I was wondering whether it is just me but over the last 2 weeks the forum has started to get very slow. Today it is very slow with 50% of the pages getting a 504 gateway timeout page. On average it takes around 30 seconds to change page, so it takes a very long time to look at 3 posts.

Many thanks for your help
Alexandra

Re: Very slow

Posted: Wed Jan 08, 2020 12:57 pm
by dhkaiser
Very slow today for me as well.

Re: Very slow

Posted: Wed Jan 08, 2020 4:06 pm
by rsfoto
Hi Solarchatforum Administrator,

Here is a site where you can analyze why a website is slow ...

Perhaps it is also a matter of the Hosting service ?

Just an Idea ...

https://gtmetrix.com/

I rmember having had a similar problem once with one of my forums and the culprit was a big image at the main site. After compressing it the site was normal again.

Just a guess but it could be that the SPOD image as it shows on every page is slowing down the site cue to the fact that is has to be loaded over and over again and the image is quite big with 11.6 MB in compressed form and 90.5 MB looking at it at full 100% size.

Perhaps putting a Thumbnail and when clicking on it it redirects to the original message ?

:?:

Re: Very slow

Posted: Wed Jan 08, 2020 5:31 pm
by Montana
Hello everyone. This morning 50% of the time the pages timed out, this was much worse than normal.

Stephen has hopefully fixed the issue this afternoon.
He has purged the cache, logged all users out, removed all orphaned filed and defragmented the database. This has improved it hugely.

However we have used up 85% of our storage space. Only 200 photos take up most of the room and of it one image being 224MB on it's own.

People must resist uploading silly sized images as the forum scales them down anyway but it still takes up space. Using Flickr or like for linking is much better. I didn't realise the SPOD wasn't linked, that is a huge file!! ;)

Alexandra

Re: Very slow

Posted: Wed Jan 08, 2020 5:54 pm
by rsfoto
People must resist uploading silly sized images ...
Hi Alexandra,

¿ is there somewhere a mentioned what are reasonable sized images so I can in future restrict the size of my images ?

Sorry, my images have in average 3.3MB will see how much I can go down in JGP compressión and not getting artifacts ...

Again I do not think it is a problem of the images itself in the topics or message but the SPOD image itself. Just a guess and the experience I had with one of my forums.

Thanks Rainer

Re: Very slow

Posted: Thu Jan 09, 2020 8:12 am
by Montana
Rainer, uploading images that are 3.3MB is not a problem at all. When folks upload images that are 20MB upwards it starts to get daft. However this wasn't the problem yesterday. The forum itself was slow for any page whether it had the SPOD there or not. It is fast today with the same SPOD so Stephen has definitely fixed the problem. As for images Stephen says "The software resizes everything before it is displayed down to 2MB or less" so I guess any image above 2MB is a waste of space?

I think the total storage space the forum has is 28GB and we are at 24GB currently so uploading an image at 224MB is a bit daft. There are no file size limits but users should use some common sense for the future as we are at 85% full. Also if any one uploads a TIFF by mistake can they delete it rather than leaving it.

Alexandra

Re: Very slow

Posted: Thu Jan 09, 2020 4:48 pm
by rsfoto
Montana wrote:
Thu Jan 09, 2020 8:12 am
Rainer, uploading images that are 3.3MB is not a problem at all. When folks upload images that are 20MB upwards it starts to get daft. However this wasn't the problem yesterday. The forum itself was slow for any page whether it had the SPOD there or not. It is fast today with the same SPOD so Stephen has definitely fixed the problem. As for images Stephen says "The software resizes everything before it is displayed down to 2MB or less" so I guess any image above 2MB is a waste of space?

I think the total storage space the forum has is 28GB and we are at 24GB currently so uploading an image at 224MB is a bit daft. There are no file size limits but users should use some common sense for the future as we are at 85% full. Also if any one uploads a TIFF by mistake can they delete it rather than leaving it.

Alexandra
Hi Alexandra,

OK. Good to know.

BTW I am hosting some forums and I have unlimited Space as well as Bandwidth and pay a year fee of about US $ 110.00 ... I pay every 3 years US 330.00 something ...

All my forums are phpBB based.

¿ maybe time to switch the Hosting company ?


my_hosting.JPG
my_hosting.JPG (23.76 KiB) Viewed 1073 times

Re: Very slow

Posted: Fri Jan 10, 2020 1:00 am
by rsfoto
Hi,

Today it is even slower then the days before ...

:shock: :shock: :shock: :shock: :shock:

Re: Very slow

Posted: Fri Jan 10, 2020 8:18 am
by Montana
Very interesting Rainer!

I too had a slow patch yesterday over lunchtime then it went quick again. I am not sure what is going on. Is it just you and me that reads this section :lol:

Is anyone else having problems?

Alexandra

Re: Very slow

Posted: Fri Jan 10, 2020 9:16 am
by Carbon60
Hi Alexandra,

It seems to be very variable. Mostly okay, but occasionally very slow, as you say. All but the smallest of images (less than a few hundred kB i.e. thumbnails) should be independently located and just linked to in order to save space. I must say, I’m surprised that our total available storage space is only 28GB. This seems a bit lightweight these days.

Thanks for raising this as an issue.

Stu.

Re: Very slow

Posted: Fri Jan 10, 2020 10:26 am
by PDB
Is it just you and me that reads this section
No, not only you ;)

Terribly slow lately. Takes me 10 minutes open and answer this ....

Regards,

Paul

Re: Very slow

Posted: Fri Jan 10, 2020 5:04 pm
by rsfoto
Hi,

A simple test would shed reflected light on this.

I know Alexandra it is your great and big :lol: Analemma image. Why not take it off for 2-3 days and let us see if it improves ?

Just an idea ...

Re: Very slow

Posted: Fri Jan 10, 2020 7:06 pm
by PDB
Rainer,

you might be correct. The image is on flickr and it is huge, (don't know if it is cached on the bbs server) but i get frequent relay-server timeouts. So there is something not good.

Paul

Re: Very slow

Posted: Fri Jan 10, 2020 10:33 pm
by Montana
Unfortunately I have no control of SPOD, only Mark T can do this ;)

I know that Stephen is looking into the problem again, I expect he has done a fault report to the host site so we will have to wait. It does seem a bit quicker tonight.

Alexandra

Re: Very slow

Posted: Sat Jan 11, 2020 6:27 pm
by dhkaiser
Still getting 504 Gateway Time-out today.

Re: Very slow

Posted: Sat Jan 11, 2020 7:41 pm
by rsfoto
dhkaiser wrote:
Sat Jan 11, 2020 6:27 pm
Still getting 504 Gateway Time-out today.
Yes, today it is really terrible ...

Re: Very slow

Posted: Sun Jan 12, 2020 12:31 pm
by Montana
Yesterday was very slow, today is lightning speed :hamster:

Alexandra

Re: Very slow

Posted: Sun Jan 12, 2020 2:42 pm
by marktownley
I've been slow to see this thread! Sorry folks. It has been up and down for me speed wise too. Hopefully Stephens fix will have helped.
Mark

Re: Very slow

Posted: Sun Jan 12, 2020 7:47 pm
by rsfoto
rsfoto wrote:
Sat Jan 11, 2020 7:41 pm
dhkaiser wrote:
Sat Jan 11, 2020 6:27 pm
Still getting 504 Gateway Time-out today.
Yes, today it is really terrible ...
Hi,

Today December 12th it is normal as usual :bow2