Grasshopper 3 test

this is the main message area for anything solar :)
User avatar
MapleRidge
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 6254
Joined: Fri Jan 13, 2012 11:58 pm
Location: Cambray, ON Canada
Contact:

Re: Grasshopper 3 test

Post by MapleRidge » Tue Oct 01, 2013 1:50 am

Beautiful images Alexandra :bow:

Brian
Brian Colville

Maple Ridge Observatory

Cambray, ON Canada

Photos: https://www.flickr.com/photos/185395281@N08/albums

etatsolarchat

Re: Grasshopper 3 test

Post by etatsolarchat » Tue Oct 01, 2013 2:05 am

Well I see the bars in Halpha and Cak, will check white light...

I may risk it and take the glass off to see if that fixes the problem..I have taken the bezel off and it did not help the problem.

gabrieli As for fircapture "flash" briefly when you adjust the shutter speed?

Yes I see that in fircapture and NOT in flycap, it's annoying... but there are many trade off between the 2 software packages, I plan to make a new thread on them soon..

rhoowl
Ohhhhhh My!
Ohhhhhh My!
Posts: 120
Joined: Wed Sep 18, 2013 1:24 pm

Re: Grasshopper 3 test

Post by rhoowl » Tue Oct 01, 2013 3:04 am

That's really good stuff.....
Jamie

Lunt ls60tha/ds/bf1200/sxvr-h814

http://astromaniac.com/

User avatar
solar
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 2251
Joined: Sun Mar 24, 2013 7:13 pm

Re: Grasshopper 3 test

Post by solar » Tue Oct 01, 2013 3:06 am

Yeah,
My 2.8 Grasshopper is the same.
Although it dosn't appear in the processed image. Thinking about it perhaps AS crops it out in surface mode?
Vixen 130ss SolarMax 90 BF30 EQ6 Pro, LX200 12", C8 CG5, Megrez80, SBIG2000 MXC,

PGR 2.8 Grasshopper PGR Flea3, DMK21 ASI 120mm Lunt B1800 Cal-K + other stuff.

Skywatcher 150mm PST Mod2

gabrieli
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 2048
Joined: Thu May 24, 2012 12:12 am
Location: Woodbridge, Ontario, Canada
Contact:

Re: Grasshopper 3 test

Post by gabrieli » Tue Oct 01, 2013 12:01 pm

Referring back to the quick "flash" when adjusting shutter speed in Firecapture:

This effect started appearing AFTER I upgraded to the latest Firecapture. It didn't ever happen before that.
What seems to be happening is that whether you are increasing or decreasing the shutter speed, the shutter speed briefly becomes long enough to make very faint features show up, i.e. faint proms.

I hope this issue is addressed in the next incarnation of the software.

Michel
Im an EXPERT!
Im an EXPERT!
Posts: 476
Joined: Thu Jun 28, 2012 11:39 am

Re: Grasshopper 3 test

Post by Michel » Tue Oct 01, 2013 2:16 pm

Bonjour Alexandra
ce test est tres interressant on voit bien la difference entre les deux cameras.
Je suis interressé par cette camera mais pas pour de suite.
Michel

User avatar
astrovale
Im an EXPERT!
Im an EXPERT!
Posts: 381
Joined: Mon Nov 28, 2011 11:25 pm

Re: Grasshopper 3 test

Post by astrovale » Wed Oct 02, 2013 2:25 pm

The detail in the prominence in the GHX shot are stunning! Your processing of that detail is that of a true master: kudos Alexandra!

Luca

etatsolarchat

Re: Grasshopper 3 test

Post by etatsolarchat » Wed Oct 02, 2013 4:58 pm

Yes you can get rid of the bars on purpose with flats, or by chance with processing, either way still very annoying that its there..

OK, I also confirm that the bars are gone with white light, also 35nm, BUT I can see them appear with 7nm filter...so seems it is a narrow band issue, something maybe inherent in the sensor and no way to fix :dry:

ALSO, I confirm today it is not the glass, I removed the glass and it did not effect the bars, I also tried moving the foam away, also no effect.

FYI, NEVER remove the glass unless you like dust spots, I had 1, now I have 15 :angry: :X

Another reason I think I like the ICX625 sensor over this one...

User avatar
swisswalter
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 17951
Joined: Thu Feb 06, 2014 4:28 am
Location: Switzerland
Contact:

Re: Grasshopper 3 test

Post by swisswalter » Thu Oct 03, 2013 8:27 pm

......I had 1, now I have 15 :angry: :X

...


Hi Eric

I'm so sorry for you
Only stardust in the wind, some fine and some less fine scopes, filters and adapters as well. Switzerland 47 N, 9 E, in the heart of EUROPE :)

from 7 am - 7 pm http://www.nanosys.ch

from 7.01 pm - 6.59 am http://www.wastronomiko.com some times vice versa ;)

donatpointgrey
Oh, I get it now!
Oh, I get it now!
Posts: 44
Joined: Mon May 28, 2012 5:06 pm

Re: Grasshopper 3 test

Post by donatpointgrey » Fri Oct 04, 2013 1:03 am

Ok - first of all a caveat... I did this because I was interested in the problem that Eric and Gabrieli reported. As a member of the research team here, I have some latitude to spend my time like this. And I hope you guys find it useful/interesting. However... please don't get me in trouble by asking me to do this on more Point Grey cameras, or by sending this forum article to our support department and say "please do what Don did for me for camera X". That'll probably get me in trouble :)

Ok? Please please?

Regarding those "bars"... sure enough, I reproduced the problem. It is always comforting to know that the world of engineering is repeatable, even when it produces results you wish were not there.

What I did was I set up a flat-field generator that I could illuminate with different single-spectrum LEDs. The device has an aperature of about F/8, with an exit pupil of about 10cm. I played around with grabbing images from an ICX674 camera and an ICX625 camera. I set the gain to 0 and turned off gamma. At first I couldn't see any problem. The images looked very flat to me. I tried with different LEDs but still couldn't see the issue. So I saved some images and tried magnifying the differences.

What I did was
- grabbed an 8-bit image (sorry, I was grabbing in 8 bit rather than 16) where the target image average was 200 greyscales
- smoothed these images substantially so I could isolate systematic changes in the image level v.s. read noise
- rescaled the images to be between 185 and 210 greyscales. That is, everything below 185 in the original image was scaled to 0, everything above 210 was scaled to 255, and everything between 185 to 210 was stretched to 0 to 255. This was to exaggerate differences in pixels

Lo and behold - I can see those bands.

I tried 3 light conditions - 652 nm (near H-a), 600-470 ("white light" - well, maybe a bit on the green/cyan side) and 416nm was as close as I had to CaK.

For the ICX674, the bands jump out in 652, they are somewhat reduced at 416, and they are all but gone in the "white light". For the ICX625 they are not there. There is some changes in signal across the sensor but it is nice and smooth. (Notice I cleaned the optical window on my ICX674 but didn't do that for the ICX625 - so please excuse the dust).

So then I went to talk to one of our sensor engineers and showed him my results and he said "yep, that is video shading, that is expected". (Note, before getting to this stage I considered a lot of other things like reflections in the cover glass, mechanical vignetting from the case, etc, without a lot of satisfaction. So it was nice to get a definitive comment from someone.)

He went on to describe to me how this occurs in the wafer fabrication process (done by Sony). Different layers are deposited across the face of the sensor with the goal that they are perfectly flat. However, near the edge of the sensor where the sensor "package" (what looks like black plastic running around the sensor active grid) there is often a change in height, and this makes it difficult to deposit a flat layer. Since there is a step in the base material, some layer material often "ramps up" slightly along this step. This causes a "frame shading" effect around the sensor active area. Different sensors will have a different height of the "step" depending on their design, so seeing differences between sensor models is normal.

Sony tests the sensors to ensure they pass a performance specification before selling these sensors. These sensors would all pass. I should point out that the framing variation of the ICX674 with WL is on the order of 0.4% - i.e. 1 greyscale. For 652 nm it is higher - about 4 or 5 greyscales at maximum and averaging about 2 or 3 along those bands. (Note in my smoothed and stretched images, each contour line you see is 1 greyscale of the sensor response).

I am sure Sony engineers would respond to feedback on this issue with a comment like "that is what flatfield compensation is for". Which doesn't really make your lives easier.

I'm not sure where you can go with this information. It is a sensor artifact based on the Sony chip and you will find it in any camera model that uses that chip (

This is the same image with the scaling to magnify the problem.


This is the ICX674 with "white" light, scaled.


ICX674 with 416 nm light


ICX625 with 652 nm light


ICX625 with "white" light
Don Murray

www.ptgrey.com

gabrieli
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 2048
Joined: Thu May 24, 2012 12:12 am
Location: Woodbridge, Ontario, Canada
Contact:

Re: Grasshopper 3 test

Post by gabrieli » Fri Oct 04, 2013 1:49 am

Don

You get an A+ for responsiveness and obvious care for users of your cameras.

I think an obvious (of course,more expensive solution?) would be to manufacture the sensors larger than their stated dimensions so that the troublesome area at the edge with this height differential is masked, outside the uniform area.

Admittedly, from my experience and others', this is mainly a H-a artifact and doesn't affect white light and it is fairly easy to reduce in a number of ways.

It's just an irritation. This, after learning that the sensor sizes quoted by all manufacturers that the measure of a sensor, say 1", doesn't really apply to any of the sensor's dimensions. It's based on an old video tube convention where the useful diagonal or diameter of a tube is actually about 2/3 of its physical dimension: an advertised 1" sensor has an actual diagonal of about 2/3".

Anyway, thank you so much for your effort in getting to the bottom of the cause of this effect and saving many adventurous
people the trouble of doing exploratory minor surgery on their cameras.

etatsolarchat

Re: Grasshopper 3 test

Post by etatsolarchat » Fri Oct 04, 2013 1:56 am

Wow Don, and I thought you were a sales guy :lol:

Glad to see it clarified and future questions on the forum can get answered directly..The more I tried to figure out the problem the more it seemed like a sensor issue..

Gabrieli, I also see it clearly in Cak, the flat I posted on this thread is Cak.

Our scopes are much more narrow band than LED's so maybe that's why its so easy for us to see..

Cropping, flats or processing can eliminate them so it can be remedied..

NOW for the dang dust I'm going to start building a clean room!!!

Thanks

User avatar
solarchat
Site Admin
Site Admin
Posts: 3977
Joined: Sat Feb 01, 2014 3:10 pm
Location: Atlanta, GA USA
Contact:

Re: Grasshopper 3 test

Post by solarchat » Fri Oct 04, 2013 1:57 am

I love my PGR cameras....
Stephen W. Ramsden
Atlanta, GA USA
Founder/Director Charlie Bates Solar Astronomy Project
http://www.solarastronomy.org

User avatar
avertedimagination
Im an EXPERT!
Im an EXPERT!
Posts: 376
Joined: Wed Oct 12, 2011 5:58 pm

Re: Grasshopper 3 test

Post by avertedimagination » Fri Oct 04, 2013 2:36 am

+1... and I like these images a lot too!

User avatar
Montana
Librarian
Librarian
Posts: 21579
Joined: Mon Oct 17, 2011 5:25 pm
Location: Cheshire, UK

Re: Grasshopper 3 test

Post by Montana » Fri Oct 04, 2013 9:04 am

Wow thanks Don :bow: :bow: :bow:

Alexandra

donatpointgrey
Oh, I get it now!
Oh, I get it now!
Posts: 44
Joined: Mon May 28, 2012 5:06 pm

Re: Grasshopper 3 test

Post by donatpointgrey » Fri Oct 04, 2013 4:30 pm

Gabrieli - the reason why they don't make larger sensors to fix video shading like you suggest is that manufacturers like us are always complaining to them to "make the package smaller". In industrial cameras, small size is always important. The smaller it is the easier it is to fit into any existing manufacturing environment. And if you make the sensor larger, you may as well make it light sensitive and let people who want to, use that area. And then you may as well market the full resolution and those who have an issue can crop. Which is exactly where you are...

Regarding "optical format" - yeah, I felt a bit cheated when I found out a 1" sensor wasn't 1" across too. :(

Eric - yeah, I'm a research guy. I'm not here because its part of my job, I'm here because I was sent to NEAIC last year and got interested enough in the area that I can't resist reading these forums from time to time.

You are also correct about the narrowness of the band. I forgot to mention my LEDs have about a 30nm spread. Also the wavelength I reported is the nominal wavelength but LEDs can drift around with temperature and age, so it is approximate.

Cheers!

Don
Don Murray

www.ptgrey.com

User avatar
swisswalter
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 17951
Joined: Thu Feb 06, 2014 4:28 am
Location: Switzerland
Contact:

Re: Grasshopper 3 test

Post by swisswalter » Sun Oct 06, 2013 1:03 pm

Hi Don

thank you very much for that inside view
Only stardust in the wind, some fine and some less fine scopes, filters and adapters as well. Switzerland 47 N, 9 E, in the heart of EUROPE :)

from 7 am - 7 pm http://www.nanosys.ch

from 7.01 pm - 6.59 am http://www.wastronomiko.com some times vice versa ;)

User avatar
eroel
Way More Fun to Share It!!
Way More Fun to Share It!!
Posts: 5100
Joined: Mon Dec 19, 2011 10:45 pm
Location: México D.F.

Re: Grasshopper 3 test

Post by eroel » Sat Nov 02, 2013 3:55 pm

Don:
Thanks for the feedback, I do remember when you went to NEAIC, we chatted a long time concerning your cameras, then I got my Chameleon.
As for the dust motes, I clean my chips and windows with air and also use an antistatic gun (the ones used for old acrilic music records), work wonders.
Best regards,
Eric (México)

Post Reply